top of page
cloud-vds.png
  • 2 Base de données

  • 2 VPS AMD

  • 4 instances ARM

  • Stockage 100 Go

  • 50k appels API

theme-light-dark-white.png

HSRP – HOT STANDBY ROUTING PROTOCOL

HSRP signifie Hot Standby Routing Protocol. Il s'agit d'un protocole propriétaire Cisco qui offre une haute disponibilité et une redondance. Il permet à un ensemble d'interfaces de routeur de fonctionner ensemble et de les présenter comme un seul routeur virtuel (passerelle par défaut) aux clients sur un réseau.


HSRP utilise une adresse MAC virtuelle et une adresse IP partagée par un groupe de routeurs configurés. Il utilise le concept Active and Standby pour la redondance. Le routeur actif est le routeur préféré pour acheminer les paquets réseau. Le routeur de secours est le routeur qui prend en charge les responsabilités de routage en cas de panne du routeur actif.


Dans cet article, nous apprendrons comment configurer HSRP sur les routeurs Cisco.


Avant de configurer HSRP, vous devez tenir compte des éléments suivants:


Les commandes de configuration d'interface suivantes sont utilisées pour définir les caractéristiques pour élire les routeurs actifs et redondants.


standby priority
standby preempt
standby track

En outre, ces commandes sont également utilisées pour définir le comportement concernant le moment où un nouveau routeur actif prendra en charge les responsabilités de routage.


Les routeurs actifs et en veille peuvent être choisis en utilisant la valeur de priorité. Si la préemption est activée, le routeur avec la priorité la plus élevée deviendra le routeur actif. Si les valeurs de priorité de deux routeurs ou plus sont égales dans un groupe de routeurs configurés, le routeur actif actuel ne sera pas modifié. La valeur de priorité peut varier de 1 à 255. Le nombre le plus élevé signifie la priorité la plus élevée et plus les chances de devenir le routeur actif. La priorité d'un routeur peut changer de manière dynamique si une interface est configurée avec la commande standby track et qu'une autre interface du routeur tombe en panne.


Configurer HSRP étape par étape


Pour configurer HSRP sur les routeurs Cisco, nous utiliserons la topologie suivante. Vous pouvez utiliser le simulateur Cisco Packet Tracer ou GNS3 pour configurer HSRP.

1. Sur le routeur WAN (souvent l'accès à Internet), exécutez les commandes suivantes pour configurer les adresses IP appropriées sur les interfaces Gig0/0 et Gig0/1 et Gig0/2.

WAN(config)#interface Gig0/0
WAN(config-if)#ip 200.200.200.1 255.255.255.0
WAN(config-if)#no shutdown

WAN(config)#interface Gig0/1
WAN(config-if)#ip address 172.16.1.1 255.255.255.0
WAN(config-if)#no shutdown

WAN(config)#interface Gig0/2
WAN(config-if)#ip address 172.16.2.1 255.255.255.0
WAN(config-if)#no shutdown

2. Une fois que vous avez configuré les adresses IP appropriées, exécutez les commandes suivantes pour configurer le protocole de routage RIP version 2.

WAN(config) #router
WAN(config-router)#version 2
WAN(config-router)#network 172.16.1.0
WAN(config-router)#network 172.16.2.0
WAN(config-router)#network 200.200.200.0
WAN(config-router)#no auto-summary
 

Une fois que vous avez configuré les adresses IP et le routage sur le routeur WAN, passez au routeur AW-R1. Ce routeur agira ensuite en tant que routeur actif.


1. Exécutez les commandes suivantes pour configurer l'adresse IP sur l'interface Gig0/1 puis sur l'interface Gig0/2.


AW-R1(config)#interface Gig0/1
AW-R1(config-if)#ip address 172.16.1.2 255.255.255.0
AW-R1(config-if)#no shutdown

AW-R1(config)#interface Gig0/2
AW-R1(config-if)#ip address 10.0.0.1 255.255.255.0
AW-R1(config-if)#no shutdown

2. Exécutez la commande suivante pour définir un numéro de groupe (1-4096) et définissez 10.0.0.150 comme adresse IP virtuelle.

AW-R1(config-if)#standby 1 ip 10.0.0.10

3. Ensuite les commandes suivantes pour définir la valeur de priorité, pour activer la préemption et pour définir l'interface track.

AW-R1(config-if)#standby 1 priority 101
AW-R1(config-if)#standby 1 preempt
AW-R1(config-if)#standby 1 track Gig0/1

4. Les commandes suivantes pour configurer le routage RIP version 2.

AW-R1(config-if)#router rip
AW-R1(config-router)#version 2
AW-R1(config-router)#network 172.16.1.0
AW-R1(config-router)#network 10.0.0.0
AW-R1(config-router)#no auto-summary
 

Maintenant, passez au routeur AW-R2 en standby et exécutez les commandes suivantes. Sur ce routeur, nous définirons la valeur de priorité sur 99 (inférieure au routeur actif).

AW-R2(config)#interface Gig0/1
AW-R2(config-if)#ip address 172.16.2.2 255.255.255.0
AW-R2(config-if)#no shutdown

AW-R2(config-if)#interface Gig0/2
AW-R2(config-if)#ip address 10.0.0.2 255.255.255.0
AW-R2(config-if)#no shutdown

AW-R2(config-if)#standby 1 ip 10.0.0.10
AW-R2(config-if)#standby 1 priority 99
AW-R2(config-if)#standby 1 preempt
AW-R2(config-if)#standby 1 track Gig0/1

AW-R2(config-if)#router rip
AW-R2(config-router)#version 2
AW-R2(config-router)#network 172.16.2.0
AW-R2(config-router)#network 10.0.0.0
AW-R2(config-router)#no auto-summary
 

Une fois que vous avez configuré le protocole de routage HSRP sur les routeurs actif et standby, il est maintenant temps de vérifier votre configuration. Pour ce faire, exécutez la commande suivante sur le routeur maître et examinez la sortie.

AW-R1#show standby

Vous pouvez voir que le routeur AW-R1 agit actuellement en tant que routeur actif car il a une priorité plus élevée (101) que le routeur AW-R2 (99).


Pour expliquer ce qui se passe lorsque le routeur actif tombe en panne, nous allons fermer l'interface Gig0/0 sur le routeur AW-R1. Pour ce faire, exécutez les commandes suivantes:

AW-R1(config) #Gig0/2
AW-R1(config-if)#shutdown

Maintenant, passez au routeur AW-R2 et exécutez la commande suivante:

show standby

Vous pouvez voir que le routeur AW-R2 devient le routeur actif et prend les responsabilités de routage dès que l'interface du routeur AW-R1 tombe en panne.


Le réseau de destination peut toujours être atteint car les clients utiliseront l'adresse IP virtuelle 10.0.0.10 comme passerelle par défaut. Lorsque le routeur R01 tombe en panne, le routeur AW-R2 prend les responsabilités de routage.

C'est ce que fait le protocole HSRP.


Dans cet article je vous ai expliqué comment configurer HSRP sur des équipements Cisco et comment cela peut aider à fournir la redondance.


N'hésitez pas à laisser un commentaire si nécessaire ! :)

Comments


Titre

Chargement...

Chargement...

Chargement...

bottom of page